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Site Maintenance Using Dreamweaver 
As you know, it is possible to transfer the files that make up your web site from your 
local computer to the remote server using FTP (file transfer protocol) or some other 
means.  There are many popular programs for doing this … for example, Fetch (Mac) or 
WS_FTP (Windows).  Using this method requires the developer to constantly keep track 
of which files are updated and, as a result, in need of being transferred to the server.  
Dreamweaver includes powerful site management capabilities that make the process of 
synchronizing files between your local computer and the server virtually transparent.  In 
order to take advantage of these capabilities, you must create a “Site,” as described 
below.  In addition to synchronizing files, Dreamweaver also facilitates the process of 
checking hyperlinks, changing a file name, or visually representing the links between the 
many files in your site.  But, before beginning, it is good to take a bit of time to consider 
the manner in which the various files within your site will be organized.1 

Organizing the site structure  

Organizing your site carefully from the beginning can save you frustration and time later 
on. If you begin creating documents without thinking about where in your folder 
hierarchy they should go, you may end up with a huge, unwieldy folder full of files, or 
with related files scattered through a lot of similarly named folders.  

The usual way to set up a site is to create a folder on your local disk that contains all the 
files for your site (referred to as the local site), and to create and edit documents within 
that folder. You then copy those files to a web server when you are ready to publish your 
site and allow the public to view it. This approach is better than creating and editing files 
on the live public website itself, because it allows you to test changes in the local site 
before making them publicly viewable, and then when you’re finished, you can upload 
the local site files and update the entire public site at once. Once you set up the local site 
with Dreamweaver, you can more easily manage your site files, track links, update pages, 
and more.  

Break down your site into categories Put related pages in the same folder. For example, 
your teaching materials, musical examples, and software reviews might all go in one 
folder, and the promotional material for your rock band might go in another folder. Use 
subfolders where necessary (e.g., for images, sound files, etc.). This type of organization 
will make your site easier to maintain and navigate.  

Decide where to put items such as images and sound files  It’s convenient to place all 
your images, for example, in one location, so that when you want to insert an image into 
a page you know where to find it. Designers sometimes place all of the non-HTML items 
to be used on a site in a folder called Assets. That folder may contain other folders—for 
example, an Images folder, a Shockwave folder, and a Sound folder. Or you might have a 

                                                 
1 Some of the information on these pages is taken from the Help files provided with Dreamweaver MX. 
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separate Assets folder for each group of related pages on your site, if there aren’t many 
assets shared among such groups. 

 

 
 
Use the same structure for local and remote sites Your local site and your remote 
website should have exactly the same structure. If you create a local site using 
Dreamweaver and then upload everything to the remote site, Dreamweaver ensures that 
the local structure is precisely duplicated in the remote site.  

Creating a New Site (back to top) 
To begin the Site Definition process: 

1. Open the New Site dialog (Site→New Site…)2 
2. There are two methods for creating a web site: 

a. Basic – uses a “wizard” to step you through the basic process 
b. Advanced (the method we will use) – allows the developer more control 

over the site 
3. Click on the “Advanced” tab to select the appropriate mode3  

 
Configuring settings for your local files: 

4. Click on “Local Info” in the list of categories 
5. Enter a name in the “Site Name” textbox; this is the label that will be used within 

Dreamweaver to refer to the site you are creating 
6. Identify the folder on the local computer that will serve as the “root directory” of 

the site you are creating 
a. this must be a unique folder for this site and this site only4 

                                                 
2 At any time, you can edit the settings for a site previously created by selecting “Edit Site…” from the Site 
menu. (Site→Edit Site…).  Alternatively, you can use the menus available in the Site panel (Window→Site 
or press F8).  There are many more site maintenance options available (recreate cache, check links, etc.) 
from the Site panel menu than there are from the Site menu in the menu selections at the top of the main 
Dreamweaver window.  The distinction between the main menus and the panel menus is an important one 
to keep in mind. 
3 This tutorial will focus only on the first two (Local Info and Remote Info) of the many categories of 
information you can enter to create a site.  Feel free to explore the other options. 
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b. you can either type in the path to the folder or click on the folder icon 
(recommended) and browse to the folder using an interface similar to 
Finder (Mac) or Windows Explorer (PC) 

7. Make sure there is a check in the box next to “Refresh Local File List 
Automatically,” so that the list of files you see in the Site Files list will always be 
up-to-date without requiring you to “refresh” the list manually 

8. Two optional (but recommended) settings: 
a. identify an images folder for the site by clicking on the folder icon to the 

right of the “Default Images Folder” textbox 
i. usually this will be a folder labeled “images” contained inside of 

the root folder for your site; if this is a new site, you can create the 
“images” folder insider of your site root directory as you proceed 
by clicking on the “new folder” icon on the Finder (Mac) or 
Windows Explorer (PC) toolbar 

b. provide the absolute address (including “http://”) to the root folder of your 
web site on the remote server; e.g., http://www.myserver.com/mysite/  

i. on the PubWeb server, a person with username “abc123” would 
enter the following info: http://pubweb.northwestern.edu/~abc123/ 

9. Make sure there is a check in the box next to “Enable Cache,” which speeds up 
the site maintenance processes 

a. at any time, you can manually update the information in cache memory by 
accessing the Site menu in the “Site” panel5 (not the Site menu in the main 
Dreamweaver window, then selecting “Recreate Site Cache” 

 
Configuring settings for the remote server: 

10. Select the “Remote Info” category 
11. From the “Access” drop-down box, select “FTP” 

a. there are other options for transferring files, but FTP (file transfer 
protocol) is the one most often used 

12. In the “FTP Host” textbox, type in the URL for your server 
a. for PubWeb, this would be “pubweb.northwestern.edu” (notice that there 

is no http:// 
i. for PubWeb sites, make sure that you do not erroneously add 

“www” to the beginning of this entry 
13. In the “Host Directory” textbox, type the path to your files 

a. on the PubWeb server, the person referenced above would type the 
following: ~abc123/public_html/6 

14. Enter the Login (i.e., your NUnet username) and password you use 
15. Make sure you are connected to the internet, then click on the “Test” button to 

check the connection to your remote server 

                                                                                                                                                 
4 You will find that creating a site that overlaps the directory structure of another site can cause problems 
… and Dreamweaver will provide a warning message if you attempt to do this. 
5 From the main Dreamweaver menu bar, select Window→Site or press F8. 
6 On PubWeb, every user’s HTML files are contained in a subfolder named “public_html” that is located 
inside a folder identified by the NUnet username.  Therefore, to access these files directly, you must 
append “public_html” to the Host Directory path. 
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a. if successful, proceed with the following steps 
b. if you do not connect successfully, you will need to troubleshoot and make 

sure that you entered all Remote Info accurately … one minor typo will 
cause the connection to fail.  DO NOT proceed until you have successfully 
tested the connection. 

16. I strongly advise that, after testing the connection successfully, you remove the 
check from the box next to “Save” to the right of the Password textbox; 
otherwise, anyone who uses Dreamweaver on the local computer will be given 
direct access to your local files AND the files on your remote server. 

17. You may wish to review the remaining options in the Remote Info category.  For 
now, just leave them all at their default (unchecked) values. 

a. Feel free to explore the other categories of information in the Site 
Definition property window.  For the time being, it is wise not to change 
any of these values unless you are absolutely certain of the function.  Any 
value set incorrectly could cause the connection to fail. 

18. When finished exploring, click on the “OK” button, then click on “Done” in the 
“Edit Sites” dialog box. 

 

Site Maintenance Tasks (back to top) 
Now that you have created a “Site” in Dreamweaver, many powerful capabilities are at 
your disposal.  It is possible to create many sites in Dreamweaver and easily navigate 
from one to the other with a single mouse click: simply select one of the sites listed in the 
“Site Files” drop-down list in the Site panel (Site→Site Files).   
 
Other capabilities include: 

Synchronizing Files 

Once you’ve created files in your local and remote sites, you can synchronize the files 
between the two sites. Use the Site→Synchronize command in the Site panel (not the 
main menu) to transfer the latest versions of your files to and from your remote site.  If 
your remote site is an FTP server (like ours), then synchronizing your files uses FTP, 
since we selected that option in the “Remote Info” category when we created our site. 

Before you synchronize your site, Dreamweaver lets you verify which files you want to 
put onto or get from your remote server. Dreamweaver also confirms which files have 
been updated after you complete the synchronization.  

To see which files are newer on the local site or the remote site, without 
synchronizing, do one of the following:  

• Choose Edit→Select Newer Local or Edit→Select Newer Remote (Windows, 
from the Site panel). 

• Choose Site→SiteFiles→View→Select Newer Local or Site→Site Files 
View→Select Newer Remote (Mac). 
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To synchronize your files:  

1. In the Site panel, choose a site from the Current Sites list pop-up menu. 
2. Select specific files or folders.  

If you want to synchronize the entire site, skip this step.  

3. In the Site panel, do one of the following to synchronize: 
o Choose Site→Synchronize. 
o Right-click (Windows) or Control-click (Macintosh), and then select 

Synchronize from the context menu. 

The Synchronize Files dialog box appears. 

4. Select the appropriate options in the dialog box that appears.  
5. Click on the “Preview” button. 
6. Dreamweaver will provide a list of all the files that need to be updated to 

synchronize your local and remote sites 
o you may “uncheck” any files that you do not want to update for any 

reason; only files that have a check mark next to them will be updated 
o To this point, Dreamweaver has made no changes to either your local or 

remote site; if you click on the “Cancel” button the Synchronnization 
process will be terminated and no files will be updated 

7. Click on the “OK” button to initiate the synchronization process 

Dreamweaver automatically synchronizes files. If the files are already in sync, 
Dreamweaver lets you know you that no synchronization is necessary.  

Checking Links in a Page or Sitewide (back to top) 

Fixing broken links (links that no longer follow a valid path or point to a nonexistent file) 
on a large site can be a tedious and time-consuming problem. This is because a large site 
can contain hundreds of links to internal and external documents, and the links might 
change over time. Orphaned files (files that still exist in the site but no other files in the 
site link to) can be a problem too, because they take up disk space and may confuse other 
team members working on the site.  

Use the Check Links feature to search for broken links and unreferenced files in an open 
file, a portion of a local site, or an entire local site. The only links that Dreamweaver 
verifies are links to documents within the site; Dreamweaver compiles a list of external 
links that appear in the selected document or documents, but does not verify them.  

When Dreamweaver finishes checking links in the specified files, it opens the Link 
Checker panel (in the Results panel group). This dialog box displays a list of broken 
links, external links (links that Dreamweaver can’t check), and orphaned files. 
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To check links within the current document:  

1. Choose File→Check Page→Check Links. 

The report appears in the Link Checker panel (in the Results panel group).  

2. To save the report, click the Save Report button in the Link Checker panel. 

Note: The target browser report is a temporary file—it will be lost if you don’t 
save it. 

To check links within a portion of a local site:  

1. In the Site panel, choose a site from the Current Sites pop-up menu. 
2. In Local view, select the files or folders to check. 
3. Initiate the check by doing one of the following: 

o Right-click (Windows) or Control-click (Macintosh) one of the selected 
files, and then choose Check Links > Selected Files/Folders from the 
context menu. 

o Choose File→Check Page→Check Links. 

The report appears in the Link Checker panel (in the Results panel group).  

4. In the Link Checker panel, select a specific link report from the Show pop-up 
menu to view another report.  

Your report choices are Broken Links and External Links. You can check for 
Orphaned Files when you check links across an entire site (see the next 
procedure).  

5. To save a report, click the Save Report button in the Link Checker panel. 

To check links in the entire site:  

1. In the Site panel, choose a site from the Current Sites pop-up menu. 
2. Choose Site→Check Links Sitewide. 

The report appears in the Link Checker panel (in the Results panel group).  

3. In the Link Checker panel, select a specific link report from the Show pop-up 
menu to view another report.  

Your report choices are Broken Links, External Links, and Orphaned Files.  

4. A list of files that fit the report type you selected appears in the Link 
Checker dialog box. 
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Note: If you select Orphaned Files as your report type, you can delete orphaned 
files from the Link Checker panel directly by selecting a file from the list and 
pressing the Delete key.  

A list of files that fit the report type you selected appears in the Link Checker 
panel.  

5. To save a report, click the Save Report button in the Link Checker panel. 

Changing File Names (back to top) 
One of the difficulties inherent in maintaining a web site as more and more files are 
added is keeping track of the many links between files.  If you ever change the name of a 
file, it is imperative that all links to that file are updated to reflect the new name, or those 
links will become “broken” and will no longer function as intended.  A significant 
advantage of enabling Dreamweaver’s cache – remember that you placed a check in this 
box when you created the site following the instructions above – is that this process 
occurs automatically.  In order to take advantage of this capability, however, it is 
absolutely essential that you change the file name from within Dreamweaver’s “Site” 
panel … not using Finder (Mac) or Windows Explorer (PC). 
 
To change a file name and all associated links: 

1. In the “Site” Panel, select the file that you wish to change, then click on it a 
second time (do not double-click the file) or it will open in the work area. 

2. When the text becomes highlighted, simply type in the new file name, then press 
RETURN (Mac) or ENTER (PC). 

3. After you enter the new filename, Dreamweaver will automatically search 
through your entire site to locate references to the changed file. 

4. If any links need to be updated, an “Update Files” dialog box will appear, giving 
you the option either to update the files or leave them as they are 

a. there are very few circumstances under which you should choose not to 
update the files; in doing so, you would essentially be creating broken 
links 

5. To complete the process, simply click on the “Update” button 
a. the files will automatically be opened, updated, and re-saved, making the 

job of site maintenance much easier than it once was!! 

Using Site Map View (back to top) 

Use the site map to view a local folder for a Dreamweaver site as a visual map of linked 
icons, to add new files to a Dreamweaver site, or to add, modify, or remove links. The 
site map is ideal for laying out a site structure. You can quickly set up the entire structure 
of the site and then create a graphic image of the site map.  

Note: The site map applies to local sites only.To create a map of a remote site, copy the 
contents of the remote site into a folder on your local disk, and then use the Edit Sites 
command to define the site as a local site.  
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