
Flash Tutorial 
©2003 Created by Scott D. Lipscomb, Associate Professor, School of Music 
 for the Teaching & Learning with Technology Workshop, Northwestern University 

Work Flow in Flash 
• draw or import graphics & sound files into Flash 
• transform buttons, independent animations, & any other elements you intend to 

reuse into “symbols” 
• place movie elements (vector graphics, bitmaps, symbols, etc.) on stage 
• attach actions to buttons, movie clips, or frames on the timeline to make them 

interactive 
o in the steps outlined below, you will find that you are strongly encouraged 

to create two specialized layers in your Flash movies: an “action” layer (to 
hold ActionScript elements) and a “sound” layer (providing a single 
location for your audio components)  

• select a frame, symbol, stroke, fill, or text block on the stage to adjust its 
properties via different panels 

Overview of Interface Elements 
• Menus 
• Toolbars (Window→Toolbars…) 
• Panels 
• Timeline 
• Stage 
• Library 
• Grid, Rulers, & Guides 
• Actions (ActionScript is the Flash scripting language) 
• Movie Explorer – provides a snapshot of your entire Flash project, including its 

construction and elements contained 

Some Specific Tools (Window→Tools) 
• Arrow tool – for selecting objects 
• Lasso – for selecting multiple objects or portions of objects 
• Line Tool 
• Pen Tool 
• Text Tool 
• Oval Tool [hold SHIFT key to create perfect circle 
• Rectangle Tool [hold SHIFT key to create perfect square] 

o notice the “round rectangle radius” button in the “Options” area that 
allows you to create rectangles with rounded corners 

o this “Options area is context sensitive, its content changing as different 
tools are selected 

• Pencil Tool, with several “modes” available in “Options” area: 
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o straighten 
o smooth 
o ink 

• Brush Tool – complex modes 
o Paint Normal 
o Paint Fills 
o Paint Behind 
o Paint Selection 
o Paint Inside 
o also Brush Size & Brush Shape options 

• Erase Tool – complex Modes 
o Erase Normal 
o Erase Fills 
o Erase Lines 
o Erase Selected Fills 
o Erase Inside 

Layers – Keeping Your Graphics Separate 
• adding additional layers 

o sound layer 
o action layer 

• hiding & locking layers 
• frame labels 

o in the Timeline, select the frame to which you wish to add a label 
o if it is not visible already, open the Properties Window 

(Window→Properties) 
o in the Frame field, type a name (keep it brief) 
o in the Timeline, deselect the frame and you will see that the frame now 

contains a flag icon, identifying it as a “label” 

Complex Graphics on a Single Layer 

When Lines Intercept & Shapes Interact 
When you create objects directly on the stage using the tools available in Flash (e.g., 
lines, ovals, rectangles, etc.), these objects do not maintain a separate identity when the 
intersect or overlap.  Try this example: 

• Select the “Oval Tool” and, in the “Colors” section of the Tool window, choose a 
Stroke color and Fill Color 

o before proceeding, in the Properties window, change the Stroke Height 
property to 5 

o you can also change the Stroke Style, if you like to change the appearance 
of the shape’s outline 

• Draw a large oval on the stage 
• Select the Arrow Tool and click somewhere in the middle of the oval you just 

created 
• Notice how the fill of the oval is selected, but the outline is not 
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o selected portions appear slightly lighter than unselected regions 
o if you want to test this out, simply press the DELETE key and notice how 

the filled portion of the oval disappears, while the outline (the “stroke”) 
remains in place; if you did delete the fill, “Undo” the last action 
(Edit→Undo) 

• Make sure that the Oval Tool is selected, set the Stroke Color to “no stroke” 
(press the button in the upper righthand corner of the Stroke Color Palette … the 
white square with the crossed out by a red line), and choose a different fill color 

• Draw a small oval inside the first oval that you drew 
• Select the Arrow Tool, select the small oval you just drew and then, using the 

arrow tool, click & drag the small oval outside of the large oval 
o notice that the area where the small oval was drawn is now no longer filled 

with the fill color of the first oval 
o as long as an object is selected, you can move it around the stage as much 

as you like and it will not cause any alteration to other objects; however, 
as soon as it is unselected (or another object is selected), it merges with 
other graphic elements on the same layer 

• If you want objects to retain their separateness when overlapping, you must place 
them on separate layers 

Guide Layers 
Allow you to create a “path” in one layer to control the action of a symbol in a “guided” 
layer; see “Motion Tweening Along a Path” below 

Mask Layers 
Allow you to focus attention on a limited area of the stage 

• single layer 
• multiple layers 

 
To create a mask layer: 

• File→New 
• Create several different colored objects on the Stage 
• Name this layer of your movie “objects” and lock it 
• Add another layer above the objects layer and name it “mask” 
• Open the layer properties window (Modify→Layer…) and change the layer type 

from “Normal” to “Mask” 
• click on the “objects” layer and open the layer properties window, then change the 

layer type from “Normal” to “Masked” and accept the change by clicking on the 
OK button 

o notice that making this change has caused the label of the “objects” layer 
to be indented and preceded by an arrow, representing the fact that this 
layer is now controlled by the “mask” layer 

• select the “mask” layer again, choose the Oval Tool, set the Stroke Color to “no 
stroke,” and set the Fill Color to black 
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• Draw a circle in the middle of the stage, covering several objects on the “objects” 
layer below 

• Control→Test Movie 
 
Notice how only the portion of the “objects” layer that shows through when the movie is 
played is the section over which the black circle was drawn in  

Reusing Objects 

Converting Graphics to Symbols & Symbol Instances 
One of the most powerful capabilities of Flash – and, for that matter, of Director – is the 
capability to reuse objects (called “symbols” in Flash or “cast members” in Director).  
Reusing objects also allows you a means of ensuring that your movie size stays relatively 
small … if you have 250 oval shapes drawn on your stage, they can all be based on the 
same “oval” symbol.  Individual ovals (called “instances” of the oval symbol) can be 
altered in several ways: 

• Library panel (WindowgLibrary) for viewing all objects contained in the current 
movie 

o To edit a symbol, simply double-click on the object in the Library; editing 
the symbol itself changes all instances based upon that symbol 

• Properties window (Window→Properties) for editing individual instances; can 
change brightness, tint, or transparency (alpha) 

• Scaling (Modify→Transform→Scale) 
• Rotation (Modify→Transform→Rotate) 
• of course, all of the techniques can be applied and/or changed over time by using 

keyframes in the movie Timeline 
 
To convert a graphic image into a symbol, simply select it and choose Insert→Convert 
to Symbol.  Once you have created a symbol, it is ready to reuse anywhere in your 
movie.  You can access all symbols used in your Flash movie via the Library window 
(Window→Library). 

Turning Bitmaps into Vector Graphics 
• place a copy of the bitmap image on the Stage 
• select the bitmap 
• Modify→Trace Bitmap 

Animation Basics 

Creating Keyframes 
• Insert→Blank Keyframe – create brand new content in new frame 
• Insert→Keyframe – duplicates contents of previous keyframe 
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To add a Motion Tween animation, follow these steps: 
• In the layer containing the object(s) you wish to animate, simply click on the 

frame where you want your animation to begin 
• When you create a new movie, the first frame of Layer 1 automatically has a 

keyframe; otherwise, you can add one (Insert→Keyframe) 
o if your objects are not yet on the stage, ensure that a keyframe on the 

appropriate layer of your movie is selected, then drag the object(s) from 
the Library onto the Stage at the location you would like for them to 
appear 

• Click on the final frame where you would like the animation to end, then select 
Insert→Timeline→Frame-> 

• Right-click (Win) or Control-click (Mac) the first keyframe of this animated 
sequence to open the pop-up menu and select “Create Motion Tween” 

o at this point a dashed line will connect the first frame of your animation to 
the last in the Timeline … this lets you know that the process is not yet 
complete 

• Click once again on the final frame of your animation and move the object(s) to 
the location where you would like it/them to be at the conclusion of this animated 
sequence 

o now the dashed line should have changed to an arrow pointing from the 
first frame of your Motion Tween animation to the last 

Sound in Flash 

Importing Sound 
• File→New 
• File→Import, then select a sound file 
• Window→Library 

o notice the sound file has been added to your movie as a Symbol 
o if you click on the “Information” icon at the bottom of the Library 

window, you can determine the appropriate level & type of compression 
for your sound file 

• Recommended: add a separate layer labeled “sound” 
• IMPORTANT: click on the placeholder frame where you want your sound file to 

play, then select Insert→Keyframe 
• with the frame containing the newly added keyframe selected, drag sound file 

from Library onto stage  
o notice that the image of the sound wave appears in the frame to confirm 

that a sound has been added 
• while the frame with the sound file is selected, notice the Properties window now 

contains additional options for manipulating the sound 
o from the “Effect” drop-down box, select Custom and notice how you can 

control the playback of your sound file; to get to this same window, you 
can simply click on the “Edit” button to the right of the “Effect” drop-
down 
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• -Control→Test Movie 

Adding Sound to a Button 
• File→New 
• Select a button from the Common Library (WindowgCommon LibrarygButtons) 

& drag an instance onto the Stage 
• Double-click on the button to enter “Symbol Edit” mode; alternatively, you can 

select Edit→Edit Symbols 
o Just below the labels on the left side of the Timeline, you should now see 

the name of the button upon which you are operating to the right of the 
“Scene 1” label 

• Decide which states (up, down, and/or over) to which you wish to attach sounds 
o IMPORTANT: If the frame where you intend to insert the sound does not 

contain a keyframe, you must add one now (Insert→Keyframe) 
• File→Import 

o select an appropriate sound for each of these states 
• Add a layer and label it “sound” 

o If the Library window is not open 
• In the “sound” layer, click on the frame representing the state to which you wish 

to add a sound, then drag the appropriate sound from the Library 
o repeat this step for every state for which you wish to add a sound 

• -Control→Test Movie 

Creating a more complex Flash movie … 

Using Common Library Elements 
• File→New 
• In the Properties window, set … 

o frame rate to “12” fps 
o set background color to a color  of your liking 

• then, click on the “Size” button and set … 
o stage width = 100 
o stage height = 75 
o set ruler unit to “pixels” 

• then, click on “Publish” and review settings for Flash, Formats, & HTML 
• save the file as “playButton.fla” 
• Window→Common Libraries→Buttons 

o find a set of buttons you like and drag an instance of a Play button to the 
Stage 

• test the movie (Control→Test Movie) 
o notice how the mouseOver, mouseDown, and mouseOut events respond to 

your interaction … nothing happens when you press the buttons, but we’ll 
get to that!! 

• close the Flash player and notice also that the image consists of layers 
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• in the Timeline, click on the layers one at a time and you will see a 
bounding box on the stage identify which portion of the image is 
represented in that layer 

• hide them one at a time, so you can see the effect 
o simply by “testing” the movie, a web-ready SWF file was created (or 

“published”) and can be inserted directly into an HTML page 
o Flash creates vector graphics … 

• on the stage, resize the Play button (ModifygTransformgScale), 
making it about 4 times as large as its original size 

• you can also set the width & height values by typing them 
directly into the Properties window (must be expanded) 

• notice that, even though the image is significantly larger, it does 
not distort 

• this is the difference between working with vector graphics 
rather than bitmap (or raster) graphics 

o if you want to insert this into a web page using Dreamweaver, … 
• start Dreamweaver 
• select the “Flash” button found on the “Common” tab of the Insert 

window 
• browse to find the SWF file you created when you tested your 

Flash movie a moment ago (not the FLA file that you edit in 
Flash), highlight the name of the file, then click on “OK 

• the SWF file is saved in the same folder as its partner FLA 
file 

• a placeholder for the Flash object is placed on your HTML page 
and can be moved around and manipulated just like other objects 
on the web page 

• to see the movie – instead of the placeholder – click on the “Play” 
button in the Properties window 

• if you do not see the “Play” button, make sure that your 
Properties window is expanded by clicking on the down-
pointing triangle in its lower right corner 

• now the movie plays as if it were in a browser window 
• click on the “Stop” button in the Properties window to return the 

Flash object to “Edit” mode 
• to see that the effect of using vector graphics within Dreamweaver 

… 
• resize the movie, making it about 4 times as large as its 

original size 
• click on the “Play” button in the Properties window again 

o voila! … the wonders of vector graphic 
• close Dreamweaver and return to Flash 

• double-click on your Play Button on the Stage (or select Edit→Edit Symbols) 
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o you have now entered Symbol Edit mode; notice that there is a new label 
(“Play”) in the upper left corner of the Timeline area next to the “Scene 1” 
label 

o click through the various button “states” (Up, Over, Down, Hit) to see 
how the image is changed; Buttons are a special type of symbol that uses 
this 4-element timeline 

• the “Hit” state is not one that you see while your button is in use, 
but its function is very important … it simply identifies the 
portion(s) of the image that are “active” 

o if you were creating your own button, you would simply edit the 
appearance of the button object on stage to reflect the desired changes 

• create a second movie entitled “stopButton.fla” 
o you can do this on your own by modifying the steps above 

Starting and Stopping Sound using Actions in Flash 
• File→New 
• In the Properties window, set … 

o frame rate to “12” fps 
o set background color to a color  of your liking 

• then, click on the “Size” button and set … 
o stage width = 250 
o stage height = 75 
o set ruler unit to “pixels” 

• Save the file as “soundButtons.fla” 
• Window→Common Libraries→Buttons 

o find a set of buttons you like and drag an instance of a Play button and a 
Stop button onto the stage; rearrange so that they are spread evenly across 
the stage & at about the same vertical position 

• you can use the Grid (ViewgGridgShow Grid) and/or Guides 
(ViewgGuidesgShow Guides), if you like, to assist with 
alignment 

• alternatively, once both objects are on the Stage, you can 
use the “Align” commands (ModifygAligng[select an 
option]) to neatly place your objects 

• these same options are also available via the Align window 
(WindowgAlign) 

• feel free to readjust the movie properties (height & width) 
• Test the movie (Control→Test Movie) 

o notice how the mouseOver, mouseDown, and mouseOut events respond to 
your interaction … nothing happens when you press the buttons, but we’ll 
get to that!! 

o as you now know, you can rescale either or both buttons 
(ModifygTransformgScale) without causing the image to pixelate 

• Import a sound file (File→Import) 
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o Set “File Type” to “All Sound Formats,” then import a sound file into your 
project 

• Open the Library Window (Window→Library) and notice that both of your 
buttons & a sound file are listed in the Window 

o in this window, you can create subfolders to organize the “assets” (Flash’s 
word for all of the elements used) in your project … for this project, since 
it is so small, it is not necessary to create any subfolders 

• Organize Layers for your Scene 
o name the layer with the buttons appropriately: “buttons” 
o in a more complex movie, you would add other layers … naming them 

helps you as you design 
• set up the Stop button, so it will cause all sounds to stop [the easy way] 

o Click on the Stop button to select it 
o Open the Actions Window (Window→Actions) 

• make certain that you are using the Actions Window in “Normal 
Mode” by clicking on the drop-down menu in the upper right-hand 
corner of the window 

o Expand the “Index” category by clicking on it and find the “Stop All 
Sounds” command from the list in the left side window, then drag this text 
into the empty area in the right window … that’s all there is to it!   You 
have now created an action that will cause the Stop button, when clicked, 
to stop playback of all sound files currently playing 

• Add sound to the Play button [a little bit harder] 
o in the Library window, double-click on the Play button to enter Symbol 

Edit mode 
• notice that next to the “Scene 1” label in the upper left-hand corner 

of the Timeline area, there is now a label with the name of the 
symbol used to create this button; you are now able to edit the 
button symbol; to return to the Scene when you are finished 
editing, simply click on the “Scene 1” label … but don’t do that 
just quite yet 

o add a Layer (Insert→Layer) and name it “sound” 
o in the “sound” layer, click on the frame under “Down” [this is the button 

state – when it is pressed – that you want to begin playback of the sound 
file], then insert a keyframe (Insert→Keyframe) 

o while the keyframe in the sound layer of the Play button is selected, add 
the desired sound by simply dragging it from the Library window on to the 
Stage 

o click on the keyframe in the sound layer again and select “Event” from the 
Sync drop-down list, since you want sound file playback to be initiated by 
the mouseDown event 

• you can also change the “Loop” value from “1” to the number of 
times you would like your sound file to play; “99” is good when 
you want to give the illusion of infinite playback 

• Click on the “Scene 1” label (upper left of the Timeline area) to leave Symbol 
Edit mode and test your movie (Control→Test Movie) 
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o clicking the Play button should cause the sound file to start playing back 
(multiple copies, if you click it more than once) 

o clicking the Stop button should cause all sound files being played to stop 

Animation 

Frame-by-Frame Animation 
Why do this, when you can use tweening… 

Shape-Tweened Animation 
morphing one shape into another 

• File→New 
• draw a square of any color with no outline in the lower lefthand corner of the 

Stage 
o use the Rectangle tool on the Drawing toolbar 
o hold the SHIFT key down to create a perfect square (same technique works 

for drawing perfect circles with the Oval tool) 
• select frame 25 on the same layer of the timeline as your square 
• Insert→Blank Keyframe 
• we are going to use text in our movie but, before adding text, you should always 

embed the font(s) you use as part of your movie, so users who do not have that 
specific font installed will still see the text as you intend them to 

o click on the context menu in the upper right corner of the Library window 
and select “New Font…” 

o type a name for your embedded font and select the font on your system 
upon which you wish to base the embedded font 

o if you want, you can set the style of the font as bold and/or italic 
• while the playback head is still on frame 25, select the Text tool and set the 

following properties in the Properties window 
o choose your embedded font (in the font list, all embedded fonts are 

followed by an asterisk 
§ hint: if you want to make your embedded font easy to find, start it 

with an underscore (“_”) character 
§ Flash comes with several fonts that are intended to be universal 

(_sans, _serif, and _typewriter), but the method above ensures that 
the font will appear as you intend 

o size = 150 
o choose any color, but different than the color of your square 

• click in the upper righthand corner of the Stage and type a capital “V” 
• select the Arrow tool and the text you just typed will be automatically selected 
• Modify→Break Apart 

o this turns the text into a shape; a necessary step to accomplish the 
“morphing” effect we want to see 

• click on Frame 1 to move the playback head to that frame 
• in the Properties window, set the following properties: 
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o choose “Shape” from the Tweening drop-down menu 
o set the Blend Type to “Angular” 

§ “distributive” works best for blending smooth, curvy shapes 
§ “angular” works best with sharp corners and straight sides 

o leave the Easing setting at its default value 
§ “easing in” causes the animation to move slower at the beginning 

and gradually increasing in speed 
§ “easing out” causes the animation to start fast and decelerate as it 

continues 
§ set to the middle, speed will remain constant 

• if you want to add “shape hints” to alter the resulting animation, simply: 
o click on the first frame of the shape tween, then select 

ModifygShapegAdd Shape Hint (or CTRL+SHIFT+H) 
o move the shape hint (the numbered circle_ to the location on the that you 

want to control 
o click on the keyframe located at the end of the shape tween and move the 

shape hint to the point in the ending shape that should correspond to the 
first point you marked 

o add additional shape hints as necessary 
o test your movie to see the results 

Motion-Tweened Animation 
• File→New 
• Click the Oval tool on the Drawing toolbar and draw a medium sized circle (no 

outline, you pick a color) in the lower left corner of the Stage 
o use the SHIFT key if you want to make a perfect circle 

• Select white as the fill color and draw a small white circle slightly on – but 
slightly off-center - the black circle (look a little like a billiard ball) 

o remember that once your shapes overlap on the same layer, you can no 
longer edit them separately; if you need to keep them separate, you must 
place the shapes on separate layers 

• Click on Frame 25 in the timeline on the same layer as the black & white circles 
• Insert→Frame 
• Right-click (Win) or Control-click (Mac) the keyframe on Frame 1 and select 

“Create Motion Tween” from the pop-up menu 
o since motion tween works only with specific items (symbol instances, 

groups, & text blocks), this command automatically converts content of 
any other type (like our “ball”) into a symbol instance 

o open the Library window and confirm that a symbol has been added called 
“Tween 1” 

o notice also that the “tween” you created is not yet complete (identified by 
the dashed line instead of an arrow pointing from the initial keyframe to 
the next) … we still have to define the end of our tweening motion 

• move the playback head to Frame 25 and click the Arrow tool in the Drawing 
toolbar 
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• drag the black ball to the middle of the right side of the Stage, adding a keyframe 
automatically to Frame 25 (notice the completed tweening arrow that is now 
displayed on the timeline between the two keyframes) 

• you can move the playback head back & forth manually to see your animation 

Customize the Motion Tween (getting in a little deeper) 
Let’s make the ball appear to grow smaller and disappear by the end of the tween 

• move the playback head to Frame 25 
• click the Arrow tool on the Drawing toolbar and select the ball 
• Modify→Transform→Scale and Rotate… 
• type “40” into the “Scale” box 

o as a result, the object will be scaled to 40% of its original size at this point 
in the animation 

• while the ball symbol in frame 25 is selected, in the Properties window, choose 
“alpha” from the “Color” drop-down list and enter “0” in the percentage box 

o setting the alpha value to “0” results in making the ball completely 
transparent, so it will seem to disappear 

• click on keyframe in Frame 1 in the timeline and, in the Properties window, set 
the following properties 

o Scale: checked 
o Rotate: CW (clockwise) 
o Times: 2 
o Orient to path: unchecked 
o Easing: -100 (all the way to the bottom of the slider) 
o Synchronize: unchecked 
o Snap: Checked 

Motion Tweening Along a Path 
• Select the layer that contains our motion-tweened animation and press the “Add 

Guide Layer” button 
o a guide layer will always appear above the layer it controls and the 

controlled layer will appear indented under the name of the motion guide 
layer 

• Click on the motion guide layer if it is not already selected as the current layer 
• Select the Pencil tool from the Drawing toolbar 

o choose “Smooth” as the pencil mode 
• Starting near the center of the ball, draw a curvy line on the stage ending up near 

the middle of the right side of the stage 
• Control→Test Movie 

Saving Animations as Graphic Symbols or Movie Clip Symbols 
Animated graphic symbols and movie clips are two kinds of animated symbols, with 
differences that – at first – may seem subtle and hard to distinguish 

• Graphic Symbol 
o tied to the timeline of any movie in which it is placed 
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o no sounds or interactivity retained, even if present in original copied 
frames 

• Movie Clip Symbol (like a film loop in Director) 
o runs on its own, independent timeline 

§ when in development environment you see only a static image 
(must Test Movie to see animation) 

§ when testing movie, continues to run animation, even if playback 
head is stopped, as long as movieClip exists in frame where it 
stops 

§ if number of frames over which animation extends changes, 
continues to run animation smoothly, without jumping from mid-
animation to the beginning 

o retain sounds and interactivity 
 
To convert existing animation into a graphic symbol or movie clip: 

• Create an animation using any method outlined above 
• Select all frames in all layers you wish to convert 
• Edit→Copy Frames 
• Insert→New Symbol 
• Type a name for your symbol 
• Select either “Graphic” (to create an animated graphic) or “Movie Clip” (to create 

a movie clip), then click on the OK button 
o Your view will then change from Movie Editing mode to Symbol Editing 

mode 
• Select Frame 1 in the symbol timeline, and choose Edit→Paste Frames 
• To return to Movie Editing Mode, click the current scene name in upper lefthand 

corner of the window 
• Open the movie library (Window→Library) and notice that your new symbol has 

been added to the list 
 
To insert graphic animation or movie clip into your movie 

• select the frame in which you want your graphic animation or movie clip to 
appear 

• drag a copy of the symbol onto the Stage 
• in the timeline, select the last frame in which you want your animation to appear 

o remember that, in determining the number of frames, you must keep in 
mind that animated graphics depend on the movie timeline, while movie 
clips do not 

• choose Insert→Frame, causing Flash to add in-between frames from the first to 
last frames selected 

• Control→Test Movie 
 
Completed movie has been saved as “movieClipVsAnimatedGraphic.fla”. 
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ActionScript – the Basics 
For interactivity, Flash requires three things 

1. an event that triggers an action 
a. mouse events (press, release, releaseOutside, rollover, rollout, dragOver, and 

dragOut) 
b. keyboard events (occur when a key on the computer keyboard is pressed) 
c. frame events (must be placed at keyframes and are triggered when the 

playback head reaches that frame in the timeline) 
d. movie clip events (load, enterFrame, unload, mouseDown, mouseUp, 

mouseMove, keyDown, keyUp, data) 
2. an action triggered by that event 

a. these actions are attached using the Actions window (Window→Actions) to 
create ActionScript 

3. the target object that performs the action or is affected by it … can be either: 
a. the current movie and its timeline 
b. other movies and their timelines (e.g., movie clip instances) 
c. external applications (e.g., internet browsers) 

 
For the following examples, make certain that the Actions Window is set to “Normal 
mode” … from the Options menu in the upper righthand corner of the Actions Window, 
choose “Normal Mode”.  It is highly recommended that you add a separate layer to your 
movie that is used exclusively for Frame Actions and label it “actions.” 
 
Adding actions to a frame: 

• select the appropriate frame in the “actions” layer of the movie timeline 
• select the desired action by doing one of the following: 

o click on the plus sign (“+”) in the upper left corner of the Actions window 
and navigate through action categories to the desired action 

o using the Toolbox List (the window in the upper left portion of the 
Actions window), navigate through the category subfolders to the desired 
action 

• to add multiple actions to a frame, simple follow the previous step until all desired 
actions have been added 

 
Editing the actions list: 

• to change the order of actions 
o select the desired action 
o click either the up or down arrow in the upper right corner above the list of 

actions in the Actions Window 
• to remove an action from the list: 

o select the desired action 
o click on the minus sign (“-”) in the upper left of the Actions window or 

press the DELETE key 
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ActionScript Examples 
To pause a movie: 

• select the frame in the “actions” layer of the movie timeline where you want your 
movie to pause 

• in the Actions Window, select Basic Actions→Stop 
• deselect the frame in your movie timeline to complete the process 

o confirm that an action has been added by noticing that a small “a” now 
appears in the intended frame of the movie timeline in the “actions” layer 

 
Using GoTo actions to navigate within your movie: 

• select the frame in the “actions” layer of the movie timeline where you want your 
movie to branch to a different location 

• in the Actions Window, select Basic Actions→Go To 
• Specify the new location: 

o in the “Scene” field, either type the Scene name or select the appropriate 
name from the drop-down list 

o specify the frame to which Flash should navigate 
• from the “Type” drop-down menu, choose one of the frame types, 

allowing you to refer to a specific frame number, frame label, the 
next/previous frame, or expression 

• if you selected “Frame Number,” “Frame Label,” or “Expression” 
in the previous step, you must provide the appropriate information 
in the “Frame” field 

o the “Go to and Play” check box should be checked if you want your movie 
to begin playing immediately when it arrives at the new location; 
otherwise, it will pause in the arrival frame 

 
A PreLoader movie 

• add a scene to your movie by clicking on the “+” in the lower right of the Scene 
Panel (Window→Panels→Scene) 

o name it “preLoader” and move it to the top of the Scene list by clicking on 
it and dragging 

• create the animation you want your user to see while the movie loads 
o an example has been provided for you (“preLoader.fla”) 

• add an “action” layer to your preLoader scene, then add the following Actions 
o in frame 1, add an “ifFrameLoaded” action (Basic Actions→If Frame 

is Loaded) 
• set the “Scene” field to the specific scene you want to begin 

playing when the movie has loaded 
• set the Frame Number or Frame Label field to the appropriate 

value … this is the amount of your movie that must be loaded 
before the “preLoader” scene will end and start playback of your 
main movie 

o in the last frame of your “preLoader” animation “Go To” action 
• set the “Scene” field to “<current scene>” 
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• set the “Type” field to “Frame Number” and the “Frame” field to 
“1” … this will cause your preLoader scene to repeat until the 
portion of the following scene you specified above has been loaded 

 
recommended 3rd party software: 
SWiS H (http://www.swishzone.com) - $49.95 (academic price: $16.95) 

• amazing program to facilitate incorporating text effects in Flash (15-day free trial) 
• sorry, Mac users … it’s Windows-only!! 

 


