
Interactive Listening Guide Template Instructions 
(including the AABA, I-vi-IV-V, and 12-bar blues templates) 

Templates developed in Flash by Dr. Scott D. Lipscomb ©2005 
 
To create your own interactive listening guide, simply follow the steps below: 

• start Flash and open the appropriate template file: 
o AABA: “aaba_template.fla” 
o I-vi-IV-V: “I-vi-IV-V_template.fla” 
o 12-bar blues: “12barBlues_template.fla” 

• immediately, save the file with a new name, so the template file always remains 
unchanged 

o I recommend adopting a simple naming convention such as: 
“aaba_SongTitle.fla” or “12barblues_SongTitle.fla,” replacing SongTitle 
with the name of the musical example you will use 

o as a general rule, you should avoid using spaces and/or special characters 
in file names that will be accessed via the internet 

• select an MP3 file that exemplifies the appropriate song structure and import it 
into the movie’s library 

o File→Import→Import to Library… 
o then browse to the file, select it, and click on the “Open” button 

• once the import process has completed … 
o click on frame 1 of the “music” layer in the Timeline panel 
o open the movie’s Library (Window→Library), select the MP3 file listed in 

the Library window, then drag-and-drop it anywhere on the Stage 
 you will know you have succeeded when you see a representation 

of the digital sound file in the “music” layer 
 in order for the Listening Guide to work properly, the sound Sync 

mode must be set to “Stream”; to check this … 
• open the Properties window (Window→Properties) and 

check the setting; if you do not see the complete set of 
options in the image below, click on the downward pointing 
triangle in the lower right corner of the Properties window 
to expand the information area 
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• Now you must increase the number of frames in your Flash movie so that it 
extends for the entire duration of your song.  In order to 
calculate this value, we must determine the duration for 
the sound file and the frame rate of our movie 

• sound file duration: 
o select the MP3 sound file in your movie’s 

Library, then open the Library Panel options 
menu by clicking in the upper right corner of the 
panel 

o select “Properties…” from the list of menu 
items 

o in the “Sound Properties” window, notice that 
the following information is provided for the 
sound file I imported: 
sample rate – 44 kHz 
channels – stereo 
bit depth – 16 bit 
duration – 166.4 seconds 
file size – 3328.0 kilobytes 

• determine the frame rate of your movie: 
o click any empty area on the stage 

and look at the Properties window, 
where you will find information 
about your movie, including its 
size, background color, and frame 
rate; the default frame rate of 12 
fps (frames per second) will work 
fine for the Listening Guide 

• to calculate the number of frames needed, simply multiply the duration of your 
musical example (in seconds) by the frame rate 

o for my song this would be 166.4 x 12 = 1,996.8 (rounded up to 1,997) 
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• in the “music” layer of the Timeline window, scroll to this frame number and 
right-click (Win) or Control-click (Mac) on that frame of the “music” layer, then 
select “Insert Frame” from the pop-up window that appears 

o you may have to do this several times, since you may be limited in the 
number of empty frames Flash will allow you to scroll [Hint: if you click 
on the Options menu in the upper right corner of the Timeline window, 
you can select “Tiny,” allowing you to see a greater number of frames at a 
single glance.  You will probably want to change this setting back to 
“Normal” once you have inserted the appropriate number of frames.] 

• for every layer except the “actions” layer, follow the directions above to insert a 
frame (not a keyframe) on this final frame of your movie 

o click on the final empty frame in the appropriate layer 
o press F5 or select Insert→Timeline→Frame 

• on the “actions” layer, select the final keyframe (frame 50 for the AABA & I-vi-
IV-V templates or frame 130 for the 12-bar blues template and release the mouse 
button.  Once the frame is selected, click-and-drag it to the final frame calculated 
in the steps above, so that the “actions” layer is equal in length to all of the other 
layers. 

o alternatively, you can right-click (Win) or Control-click (Mac) on the final 
keyframe on the “actions” layer  and select “Cut Frames,” then right-click 
(Win) or Control-click (Mac) the last frame of your movie on the 
“actions” layer and select “Paste Frames” 

Setting up the Keyframes 
You are now prepared to arrange the keyframes (the filled black circles) located on the 
“letters” layer of this Flash movie, so that they accurately represent the musical form of 
your selected musical example.  This process is a bit time-consuming, but – with practice 
– will become second nature and will allow you to create additional Listening Guides at 
the rate of about one every 10-15 minutes … well worth the time invested, when 
considered in terms of the potential enhancement of student learning and musical 
understanding. 
 
To familiarize yourself with the content of each of the keyframes contained on the 
“letters” layer, look at the content of the stage as you click on the keyframes located in 
frames 1, 10, 20, 30, & 40.  As you can see, these frames are distinguished one from 
another in the following way: 

1. AABA template 
o frame 1 – no section is highlighted 
o frame 10 – 1st “A” section is highlighted 
o frame 20 – 2nd “A” section is highlighted 
o frame 30 – “B” section is highlighted 
o frame 40 – final “A” section is highlighted 

2. I-vi-IV-V template 
o frame 1 – no section is highlighted 
o frame 10 – I-chord section is highlighted 
o frame 20 – IV-chord section is highlighted 
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o frame 30 – IV-chord section is highlighted 
o frame 40 – V-chord section is highlighted 

3. 12-bar blues template 
o frame 1 – no section is highlighted 
o frame 10 – measure 1 of 12-bar structure is highlighted 
o frame 20 – measure 2 of 12-bar structure is highlighted  
o frame 30 – measure 3 of 12-bar structure is highlighted 
o frame 40 – measure 4 of 12-bar structure is highlighted 
o frame 50 – measure 5 of 12-bar structure is highlighted 
o frame 60 – measure 6 of 12-bar structure is highlighted  
o frame 70 – measure 7 of 12-bar structure is highlighted 
o frame 80 – measure 8 of 12-bar structure is highlighted 
o frame 90 – measure 9 of 12-bar structure is highlighted 
o frame 100 – measure 10 of 12-bar structure is highlighted  
o frame 110 – measure 11 of 12-bar structure is highlighted 
o frame 120 – measure 12 of 12-bar structure is highlighted 

 
The process of setting up keyframes consists of simply moving or copying the 
appropriate keyframe to the desired location within the Flash movie.  [For this process, 
you may want to set the Timeline window to the “Tiny” setting, so you can see more 
frames concurrently; see instructions above.] 

 

 
 

To determine where a keyframe should be placed, you can use either of the two 
methods described below: 

1. use the Controller toolbar like you would to control a CD player 
a. if you don’t see this toolbar, select Window→Toolbars→Controller 

2. click-and-drag the “Playback marker” and you will hear the sound file as you 
drag (the Sync mode of the sound file must be set to “Stream”) 
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For the first chorus of your musical selection, you will need to move each of the initial 
keyframes to its appropriate position in the first chorus of the song.  The most efficient 
way to accomplish this task is to carefully follow the steps below: 

1. using the control toolbar to play back the sound file, locate within your movie the 
exact frame number where the initial keyframe should be located (i.e., the 
beginning of the first chorus of your musical form) 

2. select the keyframe on bar 10 of the template 
3. while holding the SHIFT key down, click on the final keyframe to select all 

keyframes in between frame 10 and the final keyframe 
a. the first time you do this, the final keyframe will be found in measure 40 

for the AABA and I-vi-IV-V templates and measure 120 for the 12-bar 
blues template 

4. click anywhere in the range of highlighted cells and (without releasing the mouse 
button) drag the selected frames until the first keyframe is located in the frame 
representing the beginning of the first chorus, then release the mouse button; this 
moves all keyframes at the same time 

5. next, click on the second keyframe of your musical form (highlighting the second 
“A” of the AABA form, the vi-chord of the I-vi-IV-V progression, or bar 2 of the 
12-bar blues form), and return to step three above 

6. repeat this process until you have located all four (for the AABA and I-vi-IV-V 
templates) or twelve (for the 12-bar blues template) keyframes to the appropriate 
position in the first chorus of your sound file 

 
You have now successfully completed the first chorus of your interactive musical 
listening guide and this is where the real time-saving technique comes in: 

1. using the control toolbar to play back your sound file, determine the exact frame 
number for the beginning of the next chorus of your musical example 

2. select all keyframes of the first chorus by clicking on the first keyframe, holding 
the SHIFT key while you select the final keyframe of the first chorus 

3. copy these frames by right-clicking (Win) or Control-clicking (Mac) anywhere 
within the range of selected cells and, from the pop-up menu, select “Copy 
Frames” 

4. highlight the cell identified in step #1 above and right-click (Win) or Control-
click (Mac) on it, then select “Paste Frames” from the pop-up menu that 
appears 

5. listen carefully to the chorus using the control toolbox and move the keyframes 
(select, then click-and-drag) within this chorus, so that they are located exactly 
where you want them 

6. return to step #1 above and repeat this process until you have reached the end of 
the song 

 
You will notice that each keyframe on the “letters” layer has a frame label attached as 
well.  This is an important component, since the letters on the stage – in addition to 
representing the musical form – act as buttons to initiate playback from location of the 
appropriate label, e.g., for the AABA template, clicking on the first “a” will initiate 
playback from “a1,” clicking on the “b” will initiate playback from “b,” etc.  Therefore, it 
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is imperative that these labels be attached to the keyframes to ensure the intended 
behavior is carried out.1 

Final Steps 
VERY IMPORTANT STEP:  After you have completed the process of setting all of the 
keyframes for your interactive listening guide, make certain that the length of your 
“letters” layer is equal to the length of all other layers in your movie.  Sometimes, when 
you copy-and-paste frames as you were instructed to do in the steps enumerated above, 
frames are added to that layer, causing the length of that particular layer to extend well 
beyond the end of the other layers.  All you have to do to correct this is to scroll to the 
very end of the “letters” layer, hold the CONTROL key, and click-and-drag the final frame 
of the “letters” layer back to the same frame number as the final frame of all of the other 
layers.2 
 
Customizing the Displayed Information (the easiest part!) 

• simply double-click on the two text labels (“Song Title” and “Artist”) and replace 
the text with the appropriate information for your selection. 

 
Finally, you can determine the amount of compression applied to the digital audio file 
when you “publish” your interactive listening guide.  In these templates, I have chosen 
what I consider to be appropriate settings (64 kbps, stereo, best quality), but you can 
easily change these settings to create higher quality sound (results larger SWF file size)  
or lower quality sound (smaller SWF files).  To change these settings, simply … 

• select File → Publish Settings… 
• click on the “Flash” tab at the top of the window and click on the “Set” button 

next to “audio stream” near the bottom of the window 
• change the values to your preferred settings: 

o Compression [I recommend “MP3”] 
o Preprocessing [I unchecked this box, so the sound file is stereo, but you 

can sometimes – not always – reduce your file size substantially, if you are 
willing to tolerate mono playback] 

o Bitrate [template default: “64 kbps”] – this is a major way to reduce the 
size of your online listening guide, though there is a very obvious tradeoff 
between file size and audio quality … the smaller the file size, the lower 
the quality. 
Use the following as a guide: 

 less than 64 kbps – low quality audio (the lower the bitrate, the 
lower the audio quality) 

 64 kbps – FM radio quality 
                                                 
1 You will notice that each keyframe will have a label attached, so duplicate labels will appear in your 
movie (i.e., there will be an “a1” label for each chorus of the composition).  Pressing one of the buttons on 
stage will consistently initiate playback beginning at the initial appearance of the frame label associated 
with the desired musical subsection. 
2 The importance of this step is difficult to overstate, since the value used to determine the appropriate 
location of the button on the scrollbar that moves during playback is determined by the total number of 
frames contained in the Flash movie. 
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 128 kbps – “CD quality” (in my opinion, this description is 
debatable) 

 192 kbps or higher – transparent CD audio quality 
o Quality [template default: “Best”] 

Publishing Your Listening Guide 
Once you have completed the steps outlined above, make sure to save the final version of 
your movie.  Finally, create the web-ready SWF version by selecting File→Publish…  
This will allow you to access your new interactive Listening Guide using the stand-alone 
Flash player on a local computer or to upload the SWF file to a server, allowing access 
via the web using an Internet browser with the Flash plug-in. 
 
If you have problems or wish to make suggestions for a future version of this template, 
please contact Dr. Scott D. Lipscomb at: lipscomb@northwestern.edu.  
 


